Repair Information On Your Imperial's Air Conditioning Vents

Imperial Home Page -> Repair -> Interior -> Dash -> Vents

Question from Frank (1964):

With the A/C on, often the windshield fogs or "ices up" where the cold air contacts the glass. Yet, if I pull the vents to the upright position, they won't stay. Of course, I've only had the car 10 years. I don't move too fast!! 

 Is there a practical as well as aesthetic solution to this?


From Dick:

I have found that you can ream out the 3/32 holes which retain the rowel pins to 0.125 and use 1/8 inch rowel pins instead; this is a more or less permanent cure.

The fogging sounds as is you may also have a bad heater core - check under your carpet for signs of leakage before serious damage is done to your car. If you have to add coolant, it's a good bet some of it is going out the heater core. The AC should be dehumidifying the air so that there isn't any condensation inside the car. You can add some warm air by moving the temp control so that you don't freeze yourself out, but running the AC should clear the windows almost immediately of inside condensation, and if it doesn't, suspect a heater core leak.

From John:

I usually see them with a little piece of cardboard wedged into the side. Not very pretty, but it does the job.

From Bill:

What we did for our "falling" vents, was cut a piece of thin-wall black (black interior) rubber vacuum tubing into about 1/2" long sections, then sliced them down the center so they became "U"s instead of an "O"s. We then wedged them into the corners where the vents go into their "boxes", with the inside curves wrapped around the vent's outer corners.

They act like little bushings and the vents stay put.

From Mark:

One thing you may want to check: The evaporator is housed in a cast aluminum case. At the bottom of the metal evaporator case are 4 openings nearly 2 inches in diameter. These openings, presumably for additional drainage of the evaporator, are regulated by little rubber-like discs on a stem. Since the blower on this car pulls air over the evaporator, it creates negative pressure in the evaporator housing. The theory, I suppose, was that these little rubber flaps would close when the blower was on, thereby sealing the evaporator housing to prevent intrusion of air from the engine compartment through the cowl drain openings in the firewall (and who knows where else?). The problem is that these little rubber flappers become hardened, disfigured or just plain broken. When this occurs, your blower is sucking nice warm air from the engine compartment and trying to cool it. My a/c guy found this situation when he removed my evaporator trying to find a warm air leak. Since there is already a drain tube in the evaporator case, he saw no re al need for the additional drain holes, sealed them up with a piece of metal and put the whole thing back together. Of course, you have to remove your evaporator to get to these little devils. But the trouble was worth it. My AirTemp (with 134a) went from 50 to 40 degrees at the vents on hi fan. At med and lo blower speeds and on an open stretch, it has dropped down to 32. Not bad, by any standard.

So far, so good.

Question from Donald (1967):

I took my '67 Imperial out for a drive the other day, finally a warmish day! After about 10 minutes of driving a small amount of smoke was curling from the vent to the left of the temp controls. The temp control was off. What is the most likely root cause and is the fix a major project? Another clue, maybe, early in the winter I added additional coolant to the radiator and turned on the heater to circulate the coolant through the heater. I began losing coolant until I turned off the heater (coolant was running down behind the engine but not on the floor in the car). Is this related or another problem entirely?


From John:

I'm wondering if that is hot coolent & not smoke you see? Perhaps the heater core is leaking?

From Dick:

What did the "smoke" smell like? I suspect you have a bad heater core, in which case the smell would have been of hot coolant, not a burning smell. If that is your problem, you need to replace the heater core. This is not a fun job, but it is one you can do, if you have the FSM to guide you. Most radiator shops will take your old heater core and replace the core part, making it good as new - it will probably cost under $100 if you do the R&R yourself.

From Eric:

Sounds like a leaking heater core. Had the same problem in my '68 Crown.

Follow-up from Donald:

My problem with the heater core theory is: 1) the heater was "off" when I observed the "smoke". 2) when the heater was "on" and I was losing coolant onto my garage floor none was on my carpet. Wouldn't a leaky core leak onto the carpet?

Reply from Steve:

Not necessarily. If the leak is still small the water will run out the spillway for the A/C evaporator. See if the coolant is coming out from there and you will confirm your bad heater core.

Reply from Roger:

My '55 has a leaking core as well. It's leak is evident on the firewall side. The firewall below the heater housing is damp with coolant. There was no indication of glycol smell or wet carpeting inside. The coolant flow to the heater is controlled by the temperature setting. With the setting at the coolest position, the valve restricts coolant flow to the heater core, and you will not lose coolant that way.

Check out the firewall side for moisture below the heater housing.

Reply from Russell:

Setting the temperature at the lowest setting will, indeed, restrict the coolant flow but, there will still be pressure in the heater core. It will still leak. The only way to stop the leak is to bypass the heater core (connect the hoses to each other and back to the engine). Generally, if the heater core is leaking and there is coolant in the system, it will fog up the windshield. Heater cores are relatively inexpensive but take some skill and time to replace.

Reply from Eric:

Not necessarily. My '68 had a small leak coming out of the condensation tube on the firewall.

From William:

Kind of sounds like a heater core has finally gone away. The coolant from the rear of the engine would most probably have been running out the a/c water drain pipe. You should have smelled coolant inside the car too, I suspect. Don't forget to check the water valve and hoses too.

This page last updated June 8, 2004.  Send us your feedback, and come join the Imperial Mailing List - Online Car Club.